ss-panel升级到2.x版本的一些问题

ss-panel从0.x版本升级到2.x版本的一些问题:

1. 安装后白板

ss-panel 0.x版本时候不需要 PHP 5.4支持,要使用新版本,PHP版本号必须大于 5.4。

2. 进不去管理面板

输入后台网址,进入管理面板登录页面,登陆后,提示成功,但是跳转到了用户后台并非管理后台。解决方式:

SET NAMES utf8;
SET time_zone = '+00:00';
SET foreign_key_checks = 0;
SET sql_mode = 'NO_AUTO_VALUE_ON_ZERO';

DROP TABLE IF EXISTS `ss_user_admin`;
CREATE TABLE `ss_user_admin` (
  `id` int(11) NOT NULL AUTO_INCREMENT,
  `uid` int(11) NOT NULL,
  PRIMARY KEY (`id`)
) ENGINE=InnoDB DEFAULT CHARSET=latin1;

INSERT INTO `ss_user_admin` (`id`, `uid`) VALUES
(1, 1);

3. 找回密码邮件中的链接,点击后提示链接无效

解决方式:

SET NAMES utf8;
SET time_zone = '+08:00';
SET foreign_key_checks = 0;
SET sql_mode = 'NO_AUTO_VALUE_ON_ZERO';

DROP TABLE IF EXISTS `ss_reset_pwd`;
CREATE TABLE `ss_reset_pwd` (
  `id` int(11) NOT NULL ,
  `init_time` int(11) NOT NULL,
  `expire_time` int(11) NOT NULL,
  `user_id` int(11) NOT NULL,
  `uni_char` varchar(32) NOT NULL
) ENGINE=InnoDB DEFAULT CHARSET=latin1;

ALTER TABLE `ss_reset_pwd`
MODIFY `id` int(11) NOT NULL PRIMARY KEY AUTO_INCREMENT;

INSERT INTO `ss_reset_pwd` (`id`, `init_time`, `expire_time`, `user_id`, `uni_char`) VALUES
(0,	1424448190,	1424534590,	1,	'2MzU5ODFkYzM4MmVkZTM2ZTdjNGNhNDI');

加入对话

2条评论

  1. 后台管理的问题我也遇到了 解决办法没看懂…

留下评论

电子邮件地址不会被公开。 必填项已用*标注